Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: minor updates

...

Node.js is required for several Appcelerator components, including the Axway Appcelerator CLI, Alloy, and the API Builder. Node.js is also required to build the Titanium SDK from source starting with Release 3.0.

Compatibility and download

...

If you change your prefix after installing npm packages, you will have to reinstall packages. If you change the permissions on /usr/local after installing packages as root, you may need to change the ownership of the npm cache folder, as described in Troubleshooting npm Problems.

Using NPM packages in Titanium

...

A lot of Titanium packages are found using the titanium or titanium-module keywords. Note: when creating a public common.js module and/or library file, please tag it with the titanium-module keyword.

Troubleshooting

Error: EONT, stat

...

C:\Users\<USER_NAME>\AppData\Roaming\

...

npm

The error message indicates the folder is missing.  To resolve this issue, manually create the folder:

...