This documentation relates to previous versions of Titanium Studio.

To see the latest documentation, visit docs.appcelerator.com.

Skip to end of metadata
Go to start of metadata
Chapters

Subversion Support

The Studio uses the Eclipse Subversive to provide Subversion support.

Installation

  • Open the Studio's preferences and locate the 'Available Software Sites' page.
  • Make sure that the main Eclipse update site is checked 'on'. In this example, the update site is the Eclipse 'Helios' site. Click 'OK' to commit any changes made to this page and exit.

  • Click Help -> Install New Software and select the Eclipse update site. It may take a couple of minutes to populate the plugin options.

  • Select the Subversion plugin and follow the wizard's 'Next' or 'Finish' to complete the installation.
  • Restart the Studio. Note that the Subversion plugin may ask you to download and install additional support after the restart.

Eclipse Subversive Functionality

  • Browser remote repository
  • Share project to the repository and checkout projects from the repository
  • Synchronize project to see incoming and outgoing changes
  • Commit, update and reverse changes
  • See resource change history
  • Merge changes

Import or Checkout an SVN Respository

  1. Go to File->Import
  2. Expand SVN
  3. Select Checkout Projects from SVN.
  4. Complete Wizard with your SVN repository details.

Utilize the SVN Perspective

  1. Go to Window -> Open Perspective... -> Other.
  2. Select SVN Respository Exploring

Additional SVN Questions

For advanced questions, we recommend checking out the Subversive User Guide