This documentation relates to previous versions of Titanium Studio.

To see the latest documentation, visit docs.appcelerator.com.

Skip to end of metadata
Go to start of metadata

Welcome to Aptana Studio 3. This is meant as a brief guide for how to get started in Aptana Studio 3 if you are a long-time Aptana Studio 2 user.

Chapters

Migrating Projects

Aptana Studio 2 and Aptana Studio 3 have different workspaces, so you can use the two products simultaneously. In order to work with a project in Aptana Studio 3, you will want to import your project from one workspace to the other.

It is not recommended to edit a project in both Studio 2 and Studio 3. Once you import a project, it is suggested you stick with Studio 3 for editing.

To migrate your projects from Studio 2 to Studio 3

  1. From the File menu, select Import to open a "Import" pop-up window.
  2. Select General > Existing Projects into Workspace
  3. Browse to your Aptana Studio 2 workspace folder by clicking on the top Browse... button. Click Open
  4. The "Projects" list will contain a list of all of the projects it has found. Uncheck the ones you do not wish to import.
  5. A checkbox will ask you if you wish to copy the projects into your workspace. Generally the answer is "yes," but note that that leaves a copy in the Aptana Studio 2 workspace, and a separate copy in Aptana Studio 3.
  6. Click the Finish button.

Migrating Web, PHP and Rails projects

Studio 3 changed a few things underneath the hood regarding how projects are processed. We've attempted to automate the migration process for you as you move from one environment to the other, but it's possible this process may not work in every possible circumstance. You would notice it most specifically with regards to missing content assist. In order to fix this, you'll need to reset the "Natures" on a project.

As a first step, you can try just restarting Aptana Studio. If that doesn't work, try modifying the project natures (bottom of the page here): Importing an Existing Project

Importing connections is a separate step:

  1. Select File > Import > Studio/Connections
  2. Make sure the "Workspace" radio button is selected, and browse to your Aptana Studio 2 workspace
  3. Click Finish. Your connections will show up in the Remote Connections view, and attached to projects.

You can repeat this process multiple times and it will not re-import duplicates.

File View/Remote Connections

File View has been replaced by a "Local Filesystem" node in the Project Explorer view. The "Connections" note is now visible from the "Remote" view, available in Window > Show View > Remote

Another change is that "Untitled Files" of various types (i.e. Untitled HTML File, Untitled CSS File) are no longer supported in the new file wizard. While a useful feature, it led to a great deal of hacked-together workarounds in the underlying code base. We are looking at how we may be able to bring this feature back in a future release.

Content Assist

Studio 3 simplified greatly the concept of adding JavaScript content assist. Rather than a references view that needed to be constantly updated, we've instead allowed the user to drop content assist files into an existing project to get good code assist that way. We've ported over all of the libraries we can from Studio 2, but some work needs to be done in getting content assist files for additional libraries like MootTools and node.js. If you are interested in helping, please let us know.

PHP

Studio 2 utilized the Eclipse PHP Development Tools for PHP support. Studio 3 introduces a separate PHP plugin so that we better integrate PHP support throughout the product, and to reduce the overall install footprint. For those who prefer the PDT editors, you can either install the existing PDT all-in-one distro, and add Aptana Studio, or install PDT into Aptana Studio 3.

Rails

Aptana Studio 3 includes RadRails, so no separate download is required. We've removed some of the helper views from before, as most rails developers are familiar with how to do many of the tasks on the command line that those views facilitated. For more information, see Rails Development.

Customization/Preferences

Formatting preferences are the most notable change, but in general, the defaults should be relative similar. See here for more details: Differences between Studio 2 and Studio 3

Scripting

Aptana Studio 3 introduced the concept of Rubles, Ruby-based scripting bundles based on Textmate bundles. A number of these bundles have been ported already, and a rich SDK exists for users who want to create or extend existing bundles. If you were using Eclipse Monkey, we are investigating adding JavaScript scripting support as another mechanism for Scripting Studio, but there is no firm ETA on that yet. However, everything that could be done in Eclipse Monkey can be done with Rubles, and the documentation and existing Rubles should give plenty of examples.

Previewing Files/Run/Launch Configurations

Studio 2 relied on an internal browser preview utilizing the native platform browser. Studio 3 instead relies on Chromium for previewing, a WebKit-based browser. You can find out more about previewing files here: Preview a project in your web browser.

Launch configurations may be exported and imported using the standard Eclipse export/import mechanism. See here: Exporting and importing preferences.

Colorization/Themes

Aptana Studio 3 uses a different mechanism for colorizing files than Aptana Studio 2 did. There is no converter yet, but you can use any existing Textmate theme you like. If you'd like to create your own theme, you can read more about it.

Labels
  • None