This documentation relates to previous versions of Titanium Studio.

To see the latest documentation, visit docs.appcelerator.com.

Skip to end of metadata
Go to start of metadata
Chapters

CVS Support

The Studio uses the Eclipse CVS to provide CVS support.

Installation

In case you installed the Studio as a plugin to eclipse distribution, CVS is already bundled and ready to be used. In any other case, follow these instructions to install the CVS support.

  • Open the Studio's preferences and locate the 'Available Software Sites' page.
  • Make sure that the main Eclipse update site is checked 'on'. In this example, the update site is the Eclipse 'Helios' site. Click 'OK' to commit any changes made to this page and exit.

  • Click Help -> Install New Software and select the Eclipse update site. It may take a couple of minutes to populate the plugin options.

  • Select the CVS plugin and follow the wizard's 'Next' or 'Finish' to complete the installation.

Eclipse CVS Functionality

  • Browser remote repository
  • Share project to the repository and checkout projects from the repository
  • Synchronize project to see incoming and outgoing changes
  • Commit, update and reverse changes
  • See resource change history
  • Merge changes

Import or Checkout an CVS Respository

  1. Go to File->Import
  2. Expand CVS
  3. Select Checkout Projects from CVS.
  4. Complete Wizard with your CVS repository details.

Utilize the CVS Perspective

  1. Go to Window -> Open Perspective... -> Other.
  2. Select CVS Respository Exploring

Additional CVS Questions

For advanced questions, we recommend checking out the CVS FAQ