This documentation relates to previous versions of Titanium Studio.

To see the latest documentation, visit docs.appcelerator.com.

Skip to end of metadata
Go to start of metadata
Chapters

This page explains what the Bookmarks View is and how to display it.

Introduction

The Bookmarks View lists all of your bookmarks in all of your open projects. Add bookmarks to places in your code that you think you will want to access quickly or often.

Double-click any bookmark in the Bookmarks View to immediately jump to that spot in your code. (The file containing the bookmark does not need to be open. Aptana will open the file in the editor for you.)

Opening the View

To display the Bookmarks View:

  • From the Window menu, select Show View > Other..., and in the Show View window, select General > Bookmarks.
  • To close the Bookmarks View, click the Close button (X) in the upper right of the tab.

Studio displays the Bookmark View as a tab at the bottom of your screen, shown in the image below.

Adding a Bookmark

To add a bookmark to your code:

  1. Click on the line of code where you want to add the bookmark.
  2. From the Edit menu, select Add Bookmark... from the context menu to open an Add Bookmark pop-up window.
  3. On the Add Bookmark pop-up window, type the name that you want to give to the bookmark.
  4. Click OK.

Aptana creates the bookmark for you, which now appears in the Bookmarks View.

To quickly jump to the bookmark, double-click the bookmark in the Bookmark View.

Note: You can also add a bookmark by right-clicking in the gray left margin of your editor (shown below) next to the line where you want to add the bookmark.

Related Topics

Labels