Skip to end of metadata
Go to start of metadata
Contents

Overview

A system must meet the following minimum requirements in order to run a Titanium environment.

Memory

The minimum memory requirement for Studio and the Titanium SDK is as follows:

ProductHost Operating SystemStorage
Appcelerator StudioAll1 GB (contiguous)
Latest Android SDKOS X1.5 GB (contiguous)
Latest Android SDKWindows1 GB (contiguous)
Icon

Minimum system memory requirements is 8GB of RAM. 16GB is highly recommended.



Please ask your Confluence administrator to update the license for the MultiExcerpt Plugin for Confluence 4+ .
Admin Info: The error is: license VERSION_MISMATCH

Operating System

Titanium is supported on the following Operating Systems:

Operating SystemVersion
macOS10.11.5 (Mavericks) and later
WindowsWindows 7 and later(Android)
Windows 8.1 and later (Windows Phone 8.1)
Windows 10 and later (Windows 10 Mobile)
Icon

With the release of SDK 7.0.0, we won't be supporting Windows 8.1 (Windows Phone 8.1).



Please ask your Confluence administrator to update the license for the MultiExcerpt Plugin for Confluence 4+ .
Admin Info: The error is: license VERSION_MISMATCH

Required Software

The Titanium SDK requires Oracle's JDK and Node.js.

If you are using Studio for Mac OS X and Windows, Studio prompts you to install the required software. 

Java Development Kit

Oracle's Java Development Kit (JDK) is required to be installed in order to work with Titanium.

Icon

Be aware that no other flavors of JDK, such as OpenJDK, currently work with Titanium; only Oracle's will suffice.

Titanium supports the following versions of JDK for each respective Operating System:

Operating System

Min JDK Version

Max JDK Version

Package Arch Version

Download Location

Notes

OS X

8

8 latest revision

64-bit

Official Website

  • On Mac OS X 10.6 (Snow Leopard) and earlier, the JDK is preinstalled.
  • On Mac OS X 10.7 (Lion) and later, the OS should prompt you to install it when needed. 
  • Android Development on OS X systems requires Java 6 runtime to be installed.

Windows

8

8 latest revision

32-bit only (x86 / i586)

Official Website

  • The 32-bit version of the JDK is required regardless of whether Titanium is running on a 32-bit or 64-bit Windows system.
  • Studio offers to install JDK 7 if no JDK is found.

See Installing Oracle JDK for detailed instructions.

Node.js

To run all Appcelerator components, you must have Node.js 0.10.x or later.

On Mac OS X and Windows, if you have selected to install Titanium updates, Studio prompts you to install Node.js. On Linux, you need to manually install Node.js.

Operating System

Min Node Version

Max Node Version

Download Location

macOS / Windows / Linux

6.x

8.x

Official Website

See Installing Node for detailed instructions.

Titanium Compatibility Matrix

To minimize the risk of problems, please refer to the Titanium Compatibility Matrix whenever you make changes to your Titanium environment.

 

  • No labels