Skip to end of metadata
Go to start of metadata

This document provides answers and links to commonly asked questions about Studio.

 

Which version of Java should I use with Windows?

The JDK needs to be 32bit whether Windows running 32 or 64 bit.

Check Android and set Android SDK version

You can see which ones you have installed using appc ti info -t android (Android Platforms) and select the one to use via tiapp.xml. It will default to 21 atm. See Android SDK / Target Android Platform for more details.

How do I resolve this error: [ERROR] : invalid request

Please open your terminal and type: appc login. Login with your credential and restart Axway Appcelerator Studio. 

Error during installation IDE recommended updates

Execute the following commands:

Note: for Windows users, execute the same commands without the sudo command within the administrative command prompt.

Setup Android SDK for Studio on Windows

  1. Download the Android SDK manually.
  2. Move the downloaded file in C: directory. Go to the Android SDK > tools and click on Android and select all tools, Android-6, and Extra folder then install those packages.
  3. Setup Android SDK via the command prompt:
    1. appc ti config android.sdk  /<SDK location>/
    2. appc ti setup android
  4. Restart Windows.

Install Appcelerator Studio on the Mac

  1. Download node.js and install it. Note: refer to Titanium Compatibility Matrix#Node.js for which version to install.
  2. Install Appcelerator CLI via the terminal:

  3. Download and install Studio . Installing Studio automatically installs all other prerequisite software.

Appcelerator Studio is unable to install latest appc CLI due to proxy/network configuration issues

  1. Open a terminal and execute this command: appc use latest
  2. If you get the same error what you reported, verify your proxy configuration by executing this command: appc config get proxyServer
  3. If this proxy configuration command shows any configured proxy and it was set unintentionally, you can remove it by executing this command: appc config set proxyServer
  4. If there is no proxy configured but the issue still remains, it may be that your network firewall is not allowing accessing to Appcelerator Software Update site. Contact your network admin to unblock that site.

Accessing the Log from Studio

In Studio, go to Help > Studio > View Log File. This will open the log file in an editor window where you can save the log info to a separate file.

Accessing the Log from the File System

Current log file is located in the ../.metadata directory in your workspace directory. The following lists the path for various operating systems:

  • Windows XP: C:\Documents and Settings\username\My Documents\<Studio Workspace>\.metadata\.log
  • Windows Vista/Windows 7: C:\Users\username\Documents\<Studio Workspace>\.metadata\.log
  • Mac OS X: ~/Documents/<Studio Workspace>/.metadata/.log

Fresh installation of Studio for Windows

If you download the Appcelerator Studio and install it, the installation process will cover all the steps automatically. But, sometimes, the installation process may encounter an issue. If this is the case, it may be better to install all other prerequesities and then install Studio.

  1. Install 32bit Java. Review the info in  Installing Oracle JDK  for Windows setup.
  2. Download node.js and install it. Note: refer to Titanium Compatibility Matrix#Node.js for which version to install.
  3. Execute the following commands via the admin command prompt:

  4. Download and install Studio . Installing Studio automatically installs all other prerequisite software.
  5. Launch Studio.

Installing x86 Emulator Packages

Maximum versions of the Android API are available with Intel x86 emulators. Look for the "Intel x86 Atom System Image" in the Android SDK Manager.

Go to Android SDK > tools and click on Android and select all tools, Android-6, and Extra folder(Intel x86 emulator accelerator (HAXM)). Install those packages.

The x86 emulator may run faster than the standard ARM emulator but may show minor differences with the ARM emulator. Extra software is required to take advantage of the x86 emulator. See Run Apps on the Android Emulator in the Android Tools documentation for details.

The Extra software is Intel x86 emulator accelerator (HAXM).

How to enable analytics in a new Appcelerator project?

To enable analytics in a new Appcelerator project:

  1. In Studio, create a new Mobile Application (File > New Mobile App Project...).
  2. Make sure the Enable Appcelerator Services option in enabled in the New Mobile App Project dialog and select the appropriate organization from the Organization pop-up menu. The application is tied to the account and organization used to create it.
  3. Enter the rest of the required project information and click Finish.
  4. Build your application and deploy to devices to begin collecting analytics data.

Error: com.appcelerator.install.use.download.error

Please try following steps:

  1. Open terminal (Mac) or administrative command prompt (Windows) and type: appc config get proxyServer
  2. After the first command has finished, execute this one: appc config set proxyServer null
  3. Try logging in again and enter your credentials: appc login
  4. Launch Studio and try to log in again.

How do I generate GUID on MAC

  1. Select your project.
  2. Open Studio terminal and execute: uuidgen
  3. Copy the output and open tiapp.xml  file.
  4. Find <guid> tag and replace the value with the copied value from the terminal output.
  5. Clean your project several times and build.
  6. If you still get the error, close Studio, reopen, and build again.

No Android SDK found

  1. Go to your Android SDK folder/tools/android. This will open Android SDK manager. 
  2. Download and install the recommended SDK tools and build tools. 
  3. Restart your computer after the installation is done.

If the issue happens after installing Titanium SDK from IDE recommendation, it possible your SDK installation ran into some error during installation. You need to manually download the SDK and install it.

This document provides answers and links to commonly asked questions about Studio.

 

Which version of Java should I use with Windows?

The JDK needs to be 32bit whether Windows running 32 or 64 bit.

Check Android and set Android SDK version

You can see which ones you have installed using appc ti info -t android (Android Platforms) and select the one to use via tiapp.xml. It will default to 21 atm. See Android SDK / Target Android Platform for more details.

How do I resolve this error: [ERROR] : invalid request

Please open your terminal and type: appc login. Login with your credential and restart Axway Appcelerator Studio. 

Error during installation IDE recommended updates

Execute the following commands:

Note: for Windows users, execute the same commands without the sudo command within the administrative command prompt.

Setup Android SDK for Studio on Windows

  1. Download the Android SDK manually.
  2. Move the downloaded file in C: directory. Go to the Android SDK > tools and click on Android and select all tools, Android-6, and Extra folder then install those packages.
  3. Setup Android SDK via the command prompt:
    1. appc ti config android.sdk  /<SDK location>/
    2. appc ti setup android
  4. Restart Windows.

Install Appcelerator Studio on the Mac

  1. Download node.js and install it. Note: refer to Titanium Compatibility Matrix#Node.js for which version to install.
  2. Install Appcelerator CLI via the terminal:

  3. Download and install Studio . Installing Studio automatically installs all other prerequisite software.

Appcelerator Studio is unable to install latest appc CLI due to proxy/network configuration issues

  1. Open a terminal and execute this command: appc use latest
  2. If you get the same error what you reported, verify your proxy configuration by executing this command: appc config get proxyServer
  3. If this proxy configuration command shows any configured proxy and it was set unintentionally, you can remove it by executing this command: appc config set proxyServer
  4. If there is no proxy configured but the issue still remains, it may be that your network firewall is not allowing accessing to Appcelerator Software Update site. Contact your network admin to unblock that site.

Accessing the Log from Studio

In Studio, go to Help > Studio > View Log File. This will open the log file in an editor window where you can save the log info to a separate file.

Accessing the Log from the File System

Current log file is located in the ../.metadata directory in your workspace directory. The following lists the path for various operating systems:

  • Windows XP: C:\Documents and Settings\username\My Documents\<Studio Workspace>\.metadata\.log
  • Windows Vista/Windows 7: C:\Users\username\Documents\<Studio Workspace>\.metadata\.log
  • Mac OS X: ~/Documents/<Studio Workspace>/.metadata/.log

Fresh installation of Studio for Windows

If you download the Appcelerator Studio and install it, the installation process will cover all the steps automatically. But, sometimes, the installation process may encounter an issue. If this is the case, it may be better to install all other prerequesities and then install Studio.

  1. Install 32bit Java. Review the info in  Installing Oracle JDK  for Windows setup.
  2. Download node.js and install it. Note: refer to Titanium Compatibility Matrix#Node.js for which version to install.
  3. Execute the following commands via the admin command prompt:

  4. Download and install Studio . Installing Studio automatically installs all other prerequisite software.
  5. Launch Studio.

Installing x86 Emulator Packages

Maximum versions of the Android API are available with Intel x86 emulators. Look for the "Intel x86 Atom System Image" in the Android SDK Manager.

Go to Android SDK > tools and click on Android and select all tools, Android-6, and Extra folder(Intel x86 emulator accelerator (HAXM)). Install those packages.

The x86 emulator may run faster than the standard ARM emulator but may show minor differences with the ARM emulator. Extra software is required to take advantage of the x86 emulator. See Run Apps on the Android Emulator in the Android Tools documentation for details.

The Extra software is Intel x86 emulator accelerator (HAXM).

How to enable analytics in a new Appcelerator project?

To enable analytics in a new Appcelerator project:

  1. In Studio, create a new Mobile Application (File > New Mobile App Project...).
  2. Make sure the Enable Appcelerator Services option in enabled in the New Mobile App Project dialog and select the appropriate organization from the Organization pop-up menu. The application is tied to the account and organization used to create it.
  3. Enter the rest of the required project information and click Finish.
  4. Build your application and deploy to devices to begin collecting analytics data.

Error: com.appcelerator.install.use.download.error

Please try following steps:

  1. Open terminal (Mac) or administrative command prompt (Windows) and type: appc config get proxyServer
  2. After the first command has finished, execute this one: appc config set proxyServer null
  3. Try logging in again and enter your credentials: appc login
  4. Launch Studio and try to log in again.

How do I generate GUID on MAC

  1. Select your project.
  2. Open Studio terminal and execute: uuidgen
  3. Copy the output and open tiapp.xml  file.
  4. Find <guid> tag and replace the value with the copied value from the terminal output.
  5. Clean your project several times and build.
  6. If you still get the error, close Studio, reopen, and build again.

No Android SDK found

  1. Go to your Android SDK folder/tools/android. This will open Android SDK manager. 
  2. Download and install the recommended SDK tools and build tools. 
  3. Restart your computer after the installation is done.

If the issue happens after installing Titanium SDK from IDE recommendation, it possible your SDK installation ran into some error during installation. You need to manually download the SDK and install it.

How to install App Designer in Studio

  1. Download and install Appcelerator Studio from the Appcelerator Dashboard .
  2. Open Appcelerator Studio.
  3. From the MenuBar, click on Help > Install New Software... option from the dropdown. This will open up the Available Software Dialog.
  4. Click the Add button. This will bring up a new dialog for adding a software resource.
  5. Give the software resource a Name (ex. App Designer) and Click OK. For Location, use the remote location:http://preview.appcelerator.com/appcelerator/labs/appdesigner/update/beta/
  6. In the Install New Software dialog, you should now see an option to install an Uncategorized Plugin.
  7. Click on the checkbox next to VisualUI Category and Click Next. Note: this will say Appcelerator Designer in a future release.
  8. Review and accept license agreements and proceed through the workflow. Clicking Next
  9. Click the Finish button.
  10. You will be prompted to re-start Appcelerator Studio on completion of the install.

Installing Studio on Linux

Linux systems require the GTK windowing system, Node.js, and the JDK to be installed before running Studio.

  1. Review the info in Get started with Axway Appcelerator CLI.
  2. Install CLI using the following commands:

  3. Download and install Studio .

Icon

Appcelerator Axway doesn't officially support Linux installs.

Where can I find Titanium samples?

Titanium Samples

Where can I download Studio?

  1. Log in to https://platform.appcelerator.com/.
  2. Expand the Appcelerator menu  and clicked on Studio.
  3. Download the installer or ZIP file for your operating system.

How do I configure Studio behind a proxy?

See Using Studio From Behind a Proxy for details.

How do I install Android Development Tools with Studio?

See Installing the Android Development Tools for details.

How do I install Java Development Tools with Studio?

See Installing the Java Development Tools for details.

How do I extend Studio?

See Extending Studio and select the document that is appropriate for your situation.

Can I add source control to Studio?

Yes. See Source Control for details on which source controls systems Studio can utilize.

How do I configure Studio's error reporting?

See Studio Error Reporting for details.